Archive

Posts Tagged ‘ThinkServer TS140’

Logitech M570 Centos 7 2015 Review

January 10, 2015 Leave a comment

When i first received Logitech m570 on December 2014 i tried it on Asus u46e laptop (centos 7 w 3.10.0-123.13.2.el7.x86_64 kernel) and without any problems i started to use it.

You can check that review here

Two days ago i received my new desktop (ThinkServer TS140) so i installed centos 7 (ps: centos 7 does not boot on legacy mode after installation. You have to change to uefi only mode in bios and install centos)

Attached the mouse  and nothing happens. Centos recognizes logitech but not as unifying device.

Jan  8 17:48:12 m kernel: logitech-djreceiver 0003:046D:C52B.001D: hiddev0,hidraw2: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-7/input2

so i thought maybe i forget to install some drivers, bottom line i started installation with minimal iso and i might have skip some drivers and/or libraries. After some research i found this bug report:

0007340: Broken support for Logitech Unifying Receiver – Paired mouse not recognized as HID

Seems like with 3.10.0-123 (or older ones) kernel may or may not recognize Unifying Device based on what im not sure. Some reported if there are only usb 3 then there is no problem or visa versa.

But in my situation both asus and thinkserver have usb 2 and usb 3 interfaces so i’m still not sure what is causing this bug and i didnt have time to investigate further.

Now im running 3.18.1-1 kernel on ThinkServer TS140 and m570 is working fine

Jan  8 18:10:56 m kernel: logitech-djreceiver 0003:046D:C52B.0004: hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-7/input2
Jan  8 18:10:56 m kernel: logitech-djdevice 0003:046D:C52B.0005: input,hidraw2: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:1028] on usb-0000:00:14.0-7:1